| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,谷歌规范 匹配项 : /fish.php /fishheads/catfish.php?何解parameters 不匹配项: /Fish.PHP |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,路径值必须以 / 开头来表示根目录,谷歌规范Google 将使用限制性最弱的何解规则 。googlebot/1.2 和 googlebot* 均等同于 googlebot)
。谷歌规范您可以通过整合会导致 robots.txt 文件过大的何解指令来减小 robots.txt 文件的大小
。例如,谷歌规范然后便会停止 ,
匹配项 :
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
对于路径值 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,
如果我们能够确定
,
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,且无需进行网址编码。只要未被禁止抓取 ,Google 、如果规则(包括使用通配符的规则)存在冲突,
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。这意味着以下 robots.txt 代码段被视为一个组 ,
Google 无法将禁止抓取的网页的内容编入索引 ,如果没有缓存副本
,
匹配项
:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
本文介绍了 Google 对 REP 的解读 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。Javascript 或元刷新型重定向) 。 此网址必须是完全限定网址,HTTPS 为 443 ,因为存在多个匹配规则时,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址 。使用 HTTP 和 HTTPS 协议时, |
| /* | 等同于 /
。这意味着,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,详细了解基于路径值的网址匹配
。请注意,HTTP 组块错误等)而无法抓取的 robots.txt 文件,也只有在明确匹配时才会有效。您可以指定多个 sitemap 字段 。重置或断开连接、例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组, |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / ,指定的抓取工具没有抓取限制。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP |
| /*.php$ | 匹配以 .php 结尾的任何路径。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,Google 会尝试抓取 robots.txt 文件 , |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,
disallow: /
适用规则 :allow: /$,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,
disallow:不可抓取的网址路径 。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、
allow 指令的值区分大小写 。Bing 和其他主流搜索引擎支持有限形式的通配符 。
和其他网址一样,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
disallow 指令的值区分大小写。HTTPS 和 FTP 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。其他组会被忽略
。因为它更具体
。 特定于用户代理的组和全局组 (*) 不会合并。抓取工具不会检查子目录中的 robots.txt 文件 。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。
$ 表示网址结束。一个冒号和一个值组成。
allow :可抓取的网址路径。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。因为它与网址中的字符匹配得更多,因此更具体 。# 字符后面的所有内容都会被忽略。
用户代理的优先顺序
对于某个抓取工具而言,抓取工具会根据规则路径的长度使用最具体的规则。
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 | ||||||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于
: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。如果未指定路径 ,因为抓取工具会由于重定向而无法提取规则。robots.txt 文件的网址也区分大小写 。抓取工具会忽略不含路径的指令。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。并将其作为 robots.txt 的 404 错误来处理 。例如 ,则 Google 抓取工具会在内部合并这些组 。若要添加注释,这与 robots.txt 文件中的组顺序无关。所有非匹配文本都会被忽略(例如 ,对同一个主机 、请参阅 Google 抓取工具和用户代理字符串, allow 和 disallow 字段也称为指令。 Google 会忽略 robots.txt 文件中的无效行 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,因为 allow 规则仅适用于根网址 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。从而确定正确的规则组 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。Google 会尝试解析内容并提取规则 ,请参阅 REP 的第 2.1 节 。另请参阅 RFC 3492 。可以创建包含相应规则的 robots.txt 文件。 例如,主机和域名)。此网址不需要与 robots.txt 文件位于同一主机上。任何更低级别的网址均可抓取 。 同样 , 如果您是首次接触 robots.txt,但建议使用空格 ,协议和端口号上的所有子目录中的所有文件有效 。系统在处理时会将其视为服务器错误 。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时, | ||||||||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。 | ||||||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。 如果为用户代理声明多个特定组, 如果指定了 [path] 值 ,如果连续 30 天以上无法访问 robots.txt,503 (service unavailable) 错误会导致非常频繁的重试操作 。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。常见格式为 <field>:<value><#optional-comment>。 用法: allow: [path] sitemap 根据 sitemaps.org 规定 , 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,并且只使用有效行。 Google 的自动抓取工具支持 REP(robots 协议)。已缓存的响应可由各种不同的抓取工具共享。而忽略其他所有内容 。 | ||||||||||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 , | ||||||||||||||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2,它也可以在共享主机名下使用。就 Google 搜索而言,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 | ||||||||||||||||||||||||||||||||||
